Mail Server sendet keine E-Mails / invalid sender domain misconfigured dns (1&1 Virtual Server)

Problembeschreibung
Der Mail Server (Postfix) unter einem 1&1 Virtual Server schickt keine E-Mails (Betriebssystem Cent OS 5, Parallels Plesk 5) bzw. diese kommen nicht an. Dies passiert beispielsweise wenn man mit einem PHP Script und der mail() Funktion eine E-Mail versenden möchte.

Problemursache
Die Ursache lässt sich zunächst mal im Logfile finden, dass unter /usr/local/psa/var/log/maillog zu finden ist. Dort heißt es: 421 invalid sender domain 'vserver.onlinehome-server.info' (misconfigured dns?)

Jan 22 17:12:58 s15431156 postfix/smtp[15698]: E3A86213F07C: to=<>, relay=mx01.kundenserver.de[212.227.15.150]:25, delay=0.25, delays=0.04/0/0.14/0.06, dsn=4.0.0, status=deferred (host mx01.kundenserver.de[212.227.15.150] said: 421 invalid sender domain 'vserver.onlinehome-server.info' (misconfigured dns?) (in reply to RCPT TO command))

Ursache ist ein fehlerhafter Wert für den Parameter myhostname in der Postfix Konfiguration, der im Auslieferungszustand bei 1&1 vserver.onlinehome-server.info lautet. Dieser muss auf eine gültige Domain geändert werden.

Problemlösung

  1. In der Postfix Konfiguration unter /etc/postfix/main.cf muss der Parameter myhostname auf eine gültige Domain gesetzt werden. Dort müsste irgendwo stehen myhostname = vserver.onlinehome-server.info
  2. vserver.online-home-server.info ersetzen durch die auf diesem Server verwendete Domain - z.B. yourdomain.com und main.cf speichern.
  3. Postfix Einstellungen noch aktualisieren durch folgendes Kommando: postfix reload

 

Informationen

  • Fehler entdeckt
    22. Januar 2011
  • Problemgebiet
    Mail Server
  • 1&1 Produkt
    Virtual Server L
  • Betriebssystem
    Cent OS 5 mit Parallels Plesk 5
  • Keywords
    Postfix, Plesk, Mail, 1und1, PHP mail, funktioniert nicht

Kommentare